BGP.pdf

(69 KB) Pobierz
BGP Ğ P ART 1
packetlife.net
Attributes
About BGP
Name
Description
Type
Path Vector
Well-known Mandatory Ğ Must be supported and propagated
eBGP AD
20
1 Origin
Origin type (IGP, EGP, or unknown)
iBGP AD
200
List of autonomous systems which the
advertisement has traversed
Standard
RFC 4271
2
AS Path
Protocols
IP
3 Next Hop
External peer in neighboring AS
Transport
TCP/179
Well-known Discretionary Ğ Must be supported; propagation optional
Authentication
MD5
Metric for internal neighbors to reach
external destinations (default 100)
5
Local Preference
Terminology
Includes ASes which have been dropped
due to route aggregation
Autonomous System (AS)
A logical domain under the control of a
single entity
6
Atomic Aggregate
Optional Transitive Ğ Marked as partial if unsupported by neighbor
External BGP (eBGP)
BGP adjacencies which span autonomous
system boundaries
Internal BGP (iBGP)
BGP adjacencies formed within a single AS
Synchronization Requirement
A route must be known by an IGP before
it may be advertised to BGP peers
7
Aggregator
ID and AS of summarizing router
8 Community
Route tag
Optional Nontransitive Ğ Deleted if unsupported by neighbor
Multiple Exit
Discriminator (MED)
Metric for external neighbors to reach the
local AS (default 0)
4
9 Originator ID
The originator of a reflected route
10 Cluster List
List of cluster IDs
Packet Types
13 Cluster ID
Originating cluster
Open
Update
Cisco proprietary, not communicated to
peers (default 0)
--
Weight
Keepalive
Notification
Path Selection
Neighbor States
Attribute
Weight
Description
Preference
Highest
Idle Ğ Neighbor is not responding
1
Administrative preference
Active Ğ Attempting to connect
Communicated between peers
within an AS
Connect Ğ TCP session established
2
Local Preference
Highest
Open Sent Ğ Open message sent
3
Self-originated
Prefer paths originated locally
True
Open Confirm Ğ Response received
4
AS Path
Minimize AS hops
Shortest
Established Ğ Adjacency established
Prefer IGP-learned routes over
EGP, and EGP over unknown
5
Origin
IGP
Troubleshooting
6
MED
Used externally to enter an AS
Lowest
show ip bgp [summary]
7
External
Prefer eBGP routes over iBGP
eBGP
show ip bgp neighbors
8
IGP Cost
Consider IGP metric
Lowest
show ip route [bgp]
9
eBGP Peering
Favor more stable routes
Oldest
clear ip bgp * [soft]
10
Router ID
Tie breaker
Lowest
debug ip bgp [۫]
Influencing Path Selection
Weight neighbor 172.16.0.1 weight 200
MED default-metric 400
Local Preference bgp default local-preference 100
Route Map neighbor 172.16.0.1 route-map Foo
Ignore
AS Path bgp bestpath as-path ignore
Ignore Cost
Communities bgp bestpath cost-community ignore
by Jeremy Stretch
v2.1-r1
1016647066.057.png 1016647066.068.png 1016647066.079.png 1016647066.090.png 1016647066.001.png 1016647066.008.png 1016647066.009.png 1016647066.010.png 1016647066.011.png 1016647066.012.png 1016647066.013.png 1016647066.014.png 1016647066.015.png 1016647066.016.png 1016647066.017.png 1016647066.018.png 1016647066.019.png 1016647066.020.png 1016647066.021.png 1016647066.022.png 1016647066.023.png 1016647066.024.png 1016647066.025.png 1016647066.026.png 1016647066.027.png 1016647066.028.png 1016647066.029.png 1016647066.030.png 1016647066.031.png 1016647066.032.png 1016647066.033.png 1016647066.034.png 1016647066.035.png 1016647066.036.png 1016647066.037.png 1016647066.038.png 1016647066.039.png 1016647066.040.png 1016647066.041.png 1016647066.042.png 1016647066.043.png 1016647066.044.png 1016647066.045.png 1016647066.046.png 1016647066.047.png 1016647066.048.png
BGP Ğ P ART 2
packetlife.net
Configuration Example
Router A
interface Serial1/0
description Backbone to B
ip address 172.16.0.1 255.255.255.252
AS 65100
F2/0
!
interface Serial1/1
description Backbone to C
ip address 172.16.0.5 255.255.255.252
A
S1/0
S1/1
!
interface FastEthernet2/0
description LAN
ip address 192.168.1.1 255.255.255.0
172.16.0.0/30
172.16.0.4/30
AS 65200
!
router bgp 65100
no synchronization
network 172.16.0.0 mask 255.255.255.252
network 172.16.0.4 mask 255.255.255.252
network 192.168.1.0
neighbor South peer-group
neighbor South remote-as 65200
neighbor 172.16.0.2 peer-group South
neighbor 172.16.0.6 peer-group South
no auto-summary
S1/0
S1/0
F0/0
F0/0
10.0.0.0/30
B
C
F2/0
F2/0
OSPF
Router B
Router C
interface FastEthernet0/0
description Backbone to C
ip address 10.0.0.1 255.255.255.252
interface FastEthernet0/0
description Backbone to B
ip address 10.0.0.2 255.255.255.252
!
interface Serial1/0
description Backbone to A
ip address 172.16.0.2 255.255.255.252
!
interface Serial1/0
description Backbone to A
ip address 172.16.0.6 255.255.255.252
!
interface FastEthernet2/0
description LAN
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet2/0
description LAN
ip address 192.168.3.1 255.255.255.0
!
router ospf 100
network 10.0.0.1 0.0.0.0 area 0
network 192.168.2.1 0.0.0.0 area 1
!
router ospf 100
network 10.0.0.2 0.0.0.0 area 0
network 192.168.3.1 0.0.0.0 area 2
!
router bgp 65200
no synchronization
redistribute ospf 100 route-map LAN_Subnets
neighbor 10.0.0.2 remote-as 65200
neighbor 172.16.0.1 remote-as 65100
no auto-summary
!
router bgp 65200
no synchronization
redistribute ospf 100 route-map LAN_Subnets
neighbor 10.0.0.1 remote-as 65200
neighbor 172.16.0.5 remote-as 65100
no auto-summary
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
route-map LAN_Subnets permit 10
match ip address 10
set metric 100
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
route-map LAN_Subnets permit 10
match ip address 10
set metric 100
Router A Routing Table
Router B Routing Table
172.16.0.0/30 is subnetted, 2 subnets
C 172.16.0.4 is directly connected, S1/1
C 172.16.0.0 is directly connected, S1/0
C 192.168.1.0/24 is directly connected, F2/0
B 192.168.2.0/24 [20/100] via 172.16.0.2
B 192.168.3.0/24 [20/100] via 172.16.0.2
172.16.0.0/30 is subnetted, 2 subnets
B 172.16.0.4 [20/0] via 172.16.0.1
C 172.16.0.0 is directly connected, S1/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, F0/0
B 192.168.1.0/24 [20/0] via 172.16.0.1
C 192.168.2.0/24 is directly connected, F2/0
O IA 192.168.3.0/24 [110/2] via 10.0.0.2, F0/0
by Jeremy Stretch
v2.1-r1
1016647066.049.png 1016647066.050.png 1016647066.051.png 1016647066.052.png 1016647066.053.png 1016647066.054.png 1016647066.055.png 1016647066.056.png 1016647066.058.png 1016647066.059.png 1016647066.060.png 1016647066.061.png 1016647066.062.png 1016647066.063.png 1016647066.064.png 1016647066.065.png 1016647066.066.png 1016647066.067.png 1016647066.069.png 1016647066.070.png 1016647066.071.png 1016647066.072.png 1016647066.073.png 1016647066.074.png 1016647066.075.png 1016647066.076.png 1016647066.077.png 1016647066.078.png 1016647066.080.png 1016647066.081.png 1016647066.082.png 1016647066.083.png 1016647066.084.png 1016647066.085.png 1016647066.086.png 1016647066.087.png 1016647066.088.png 1016647066.089.png 1016647066.091.png 1016647066.092.png 1016647066.093.png 1016647066.094.png 1016647066.095.png 1016647066.096.png 1016647066.097.png 1016647066.098.png 1016647066.099.png 1016647066.100.png 1016647066.002.png 1016647066.003.png 1016647066.004.png 1016647066.005.png 1016647066.006.png 1016647066.007.png
Zgłoś jeśli naruszono regulamin